Microsoft Copilot – Global Service Disruption

Incident Report for California Closets

Resolved

Microsoft has resolved the issue. Copilot is back up and running for users.
Posted Jun 11, 2026 - 17:51 PDT

Investigating

Microsoft Copilot is currently experiencing a global outage. This is a Microsoft-wide issue affecting all users, and is not isolated to our environment.

We are monitoring Microsoft's status page and will provide updates as they become available.
Posted Jun 11, 2026 - 13:52 PDT
This incident affected: Microsoft (Microsoft Copilot).