CC Help Desk - Outage

Incident Report for California Closets

Monitoring

The CC Help Desk issue has been resolved and users can now access the portal. Our team will continue to monitor the platform throughout the day. If you have any trouble accessing the portal, please email support@calclosets.com or call 844-453-1216.
Posted Dec 01, 2025 - 07:39 PST

Identified

We are aware of an issue that is causing the CC Help Desk to be unreachable. Our team is working with Atlassian to resolve the issue as soon as possible. In the meantime, please direct all urgent requests to support@calclosets.com or call 844-453-1216.
Posted Nov 28, 2025 - 09:37 PST
This incident affects: CC Help Desk.